IVN13B is going FI!!!

Discuss any information on turbo charging or super charging the RX8.

Moderator: zoom

User avatar
spinner
Validated Member
Posts: 2205
Joined: Tue May 11, 2010 6:33 pm
Location: Wollongong

Re: IVN13B is going FI!!!

Post by spinner » Fri Dec 07, 2012 5:47 pm

Great news Ivan. Glad your car is back on the road, can't wait to see it at the next meet
"The ingenious and decidedly weird Wankel rotary engine works by using internal combustion to bounce a fat metal triangle around inside a hollow metal kidney bean, which hula-hoops around a central shaft to generate power"

User avatar
tiptoe
Validated Member
Posts: 3035
Joined: Sun Jan 25, 2009 6:19 pm
Location: western suburbs, NSW

Re: IVN13B is going FI!!!

Post by tiptoe » Fri Dec 07, 2012 8:09 pm

10 psi on run in time. U brave man.

Glad it's all working out.

Finally able to hear results from troys work with the microtech...seeing as the mybabi thread is dead

User avatar
skc
Validated Member
Posts: 1921
Joined: Tue Jul 20, 2004 3:05 pm
Location: Brisbane
Contact:

Re: IVN13B is going FI!!!

Post by skc » Fri Dec 07, 2012 10:34 pm

Good news. Yes, it is important that the tuner is capable and familair with the software.
skc
Hymee Supercharged (200kw at the wheels)
Lakeside 1:02.02
Wakefield 1:12.04(NA) 1:11.36(FI)

User avatar
IVN13B
Validated Member
Posts: 606
Joined: Wed Oct 05, 2011 10:04 pm
Location: PENRITH,NSW

Re: IVN13B is going FI!!!

Post by IVN13B » Sat Dec 08, 2012 6:11 am

tiptoe wrote:10 psi on run in time. U brave man.

Glad it's all working out.

Finally able to hear results from troys work with the microtech...seeing as the mybabi thread is dead
The 10 psi was seen at the ecu tune but i only drive it pretty easy and id b lucky to see 4-5psi just before the rev cut, i just ease in into all gears at 1/4 to 1/2 throttle

User avatar
IVN13B
Validated Member
Posts: 606
Joined: Wed Oct 05, 2011 10:04 pm
Location: PENRITH,NSW

Re: IVN13B is going FI!!!

Post by IVN13B » Sat Dec 08, 2012 6:14 am

tiptoe wrote:10 psi on run in time. U brave man.

Glad it's all working out.

Finally able to hear results from troys work with the microtech...seeing as the mybabi thread is dead
Btw, MYBABI, is still in the mix and ive been told that few weeks will be up and running,

User avatar
tiptoe
Validated Member
Posts: 3035
Joined: Sun Jan 25, 2009 6:19 pm
Location: western suburbs, NSW

Re: IVN13B is going FI!!!

Post by tiptoe » Sat Dec 08, 2012 11:57 am

Yeah. Troy is one of my mechanics too...I see the mybabi car often...the project continues but the thread remains dead is all I meant.

Seeing as you are having success so far with the microtech...I'll start asking...
How does it deal with any cel it may come across?

tim33h
Validated Member
Posts: 2397
Joined: Tue Jun 28, 2011 12:26 pm
Location: SW Sydney, NSW

Re: IVN13B is going FI!!!

Post by tim33h » Sat Dec 08, 2012 2:26 pm

awesome news Ivan!

User avatar
IVN13B
Validated Member
Posts: 606
Joined: Wed Oct 05, 2011 10:04 pm
Location: PENRITH,NSW

Re: IVN13B is going FI!!!

Post by IVN13B » Sat Dec 08, 2012 5:16 pm

tiptoe wrote:Yeah. Troy is one of my mechanics too...I see the mybabi car often...the project continues but the thread remains dead is all I meant.

Seeing as you are having success so far with the microtech...I'll start asking...
How does it deal with any cel it may come across?
Cel remains on all the time, but thats easily fixed by removing the lamp! Haha
Not really worried bout cel

User avatar
tiptoe
Validated Member
Posts: 3035
Joined: Sun Jan 25, 2009 6:19 pm
Location: western suburbs, NSW

Re: IVN13B is going FI!!!

Post by tiptoe » Sat Dec 08, 2012 5:28 pm

Yeah. I wouldn't be able to do that that.
I'm paranoid.

I'm glad it's working for you though.

User avatar
IVN13B
Validated Member
Posts: 606
Joined: Wed Oct 05, 2011 10:04 pm
Location: PENRITH,NSW

Re: IVN13B is going FI!!!

Post by IVN13B » Sun Dec 09, 2012 7:30 am

tiptoe wrote:Yeah. I wouldn't be able to do that that.
I'm paranoid.

I'm glad it's working for you though.
Im very conifident in what Troy at Vis has done to the motor so CEL will not be an issue.

User avatar
IVN13B
Validated Member
Posts: 606
Joined: Wed Oct 05, 2011 10:04 pm
Location: PENRITH,NSW

Re: IVN13B is going FI!!!

Post by IVN13B » Wed Dec 19, 2012 3:38 pm

Update, car is run in and on the dyno now, on 5.4psi it made 190hp at the wheels!
Stay tuned....

User avatar
IVN13B
Validated Member
Posts: 606
Joined: Wed Oct 05, 2011 10:04 pm
Location: PENRITH,NSW

Re: IVN13B is going FI!!!

Post by IVN13B » Wed Dec 19, 2012 4:19 pm

6psi 202 wheel horsepower...
Ric put in new standard coils before engine blew but they arent handling more that 6psi, so Bosch coil pack mite b on the cards

User avatar
zoom
Post WHORE!
Post WHORE!
Posts: 6096
Joined: Sun Jan 30, 2005 6:55 pm
Location: Melbourne, Australia

Re: IVN13B is going FI!!!

Post by zoom » Wed Dec 19, 2012 7:17 pm

While I am way down on power at the moment, I'm still running maybe 180-190 rwkw and I am on stock coils. Have you tried plugs/leads first?

And thinking about it, if you drove with a bad engine the coils may have been under duress for a bit.

Also are you going to run the HEC's if you go Bosch, ie with an external ignitor?
Image
Image

Mazda RX8 Club Australia | Winton: 1:42.86 | Sandown: 1:32.42 | Broadford: 1:10.45 | Wakefield: 1:15.94

User avatar
IVN13B
Validated Member
Posts: 606
Joined: Wed Oct 05, 2011 10:04 pm
Location: PENRITH,NSW

Re: IVN13B is going FI!!!

Post by IVN13B » Wed Dec 19, 2012 8:27 pm

zoom wrote:While I am way down on power at the moment, I'm still running maybe 180-190 rwkw and I am on stock coils. Have you tried plugs/leads first?

And thinking about it, if you drove with a bad engine the coils may have been under duress for a bit.

Also are you going to run the HEC's if you go Bosch, ie with an external ignitor?
Yeah ive done new plugs, and the coils are only 2 months old,
What turbo kit are u using to make 180-190kwatw?

User avatar
IVN13B
Validated Member
Posts: 606
Joined: Wed Oct 05, 2011 10:04 pm
Location: PENRITH,NSW

Re: IVN13B is going FI!!!

Post by IVN13B » Wed Dec 19, 2012 8:28 pm

Yes the bosch with external ignitor

Post Reply