Electrical problem?

Regional Forum for all in VIC

Moderator: zoom

Jason9994
Posts: 8
Joined: Sun Mar 23, 2014 1:59 pm

Re: Electrical problem?

Post by Jason9994 » Thu May 01, 2014 11:51 pm

ahh ok. Sorry im a noob lol ... when he diagnosed the car, he said something about the abs but he fixed tha. now if he does the test now, theres no faults at all. i found out that my cat isnt genuine, its just from this exhaust place in cheltenham. The cat is tiny compared to the stock one. and that cat goes glowing red after 3 minutes after starting the engine...

User avatar
zoom
Post WHORE!
Post WHORE!
Posts: 6111
Joined: Sun Jan 30, 2005 6:55 pm
Location: Melbourne, Australia

Re: Electrical problem?

Post by zoom » Fri May 02, 2014 10:03 am

The cat is to small from the sounds of it. Rotaries run exhaust gases at almost double the temp of a piston so the cat has to be purpose built. Rotaries also flow a lot of exhaust so they generally have larger exhausts.

The cherry red is a sure sign of restriction. This would normally happen on an 8 under extended heavy load only.
Image
Image

Mazda RX8 Club Australia | Winton: 1:42.86 | Sandown: 1:32.42 | Broadford: 1:10.45 | Wakefield: 1:15.94

User avatar
Kev13B
Validated Member
Posts: 2322
Joined: Fri Nov 25, 2011 4:51 pm
Location: Melbourne, Northern Suburbs.

Re: Electrical problem?

Post by Kev13B » Fri May 02, 2014 10:09 am

Yep cat is either blocked or to restrictive.
get it towed to the exhaust place as you can damage the engine or possibly melt your interior carpet. Get them to see if it's blocked if it's not get them to fix their mistake and get a high flow one that can withstand high temperatures (over 800c)
Image
Wakefield: 1:18.244 - Winton: 1:44.129
RX-8 Club Stickers

Post Reply